Emacs vertico package problem

Hi GNU/linux users

emacs la vertico la problem varudu please solve pani thanga

Config.org file

* User Interface
** Hide menubar
#+begin_src emacs-lisp
(menu-bar-mode 0)
** Hide Toolbar and Scrollbar
#+begin_src emacs-lisp
    (tool-bar-mode 0)
    (scroll-bar-mode 0)
** No inhibit startup message
#+begin_src emacs-lisp
(setq inhibit-startup-screen t)
** set number
#+begin_src emacs-lisp
(global-display-line-numbers-mode t)
** Theme
#+begin_src emacs-lisp
(load-theme 'wombat)
;(load-theme 'ef-dark t)
** Font Configuration
#+begin_src emacs-lisp
  (set-face-attribute 'default nil :font "Noto Sans Mono" :height 200)
** Cursor
#+begin_src emacs-lisp
(set-cursor-color "#523d64")
(setq-default cursor-type 'bar)

* Behavior
** No (Backup, Lock, Autosave)
#+begin_src emacs-lisp
make-backup-files nil
auto-save-default nil
create-lockfiles nil)
** Y or N instead of Yes or No
#+begin_src emacs-lisp
(fset 'yes-or-no-p 'y-or-n-p)
** Electric auto pair mode
#+begin_src emacs-lisp
(electric-pair-mode 1)
** Registers
#+begin_src emacs-lisp
(set-register ?E '(file . "/home/linux/.emacs.d/config.org"))
(set-register ?I '(file . "/home/linux/.config/i3/config"))
** Buffers
*** Buffer switching
#+begin_src emacs-lisp
   (global-set-key [(meta shift j)] 'previous-buffer)
   (global-set-key [(meta shift l)] 'next-buffer)
*** Buffer kill
#+begin_src emacs-lisp
   (global-set-key (kbd "C-x K") 'kill-this-buffer)

* Use package
** Installation
#+begin_src emacs-lisp
(require 'package)

(setq package-archives '(("melpa" . "https://melpa.org/packages/")
			("org" . "https://orgmode.org/elpa/")
			("elpa" . "https://elpa.gnu.org/packages/")))

(unless package-archive-contents

;; Initialize use package on non-linux based system
(unless (package-installed-p 'use-package)
  (package-install 'use-package))

(require 'use-package)
(setq use-package-always-ensure t)
* Third party packages
** Nerd icons
#+begin_src emacs-lisp
;(use-package nerd-icons)
** Which Key
#+begin_src emacs-lisp
(use-package which-key
:init (which-key-mode)
:diminish which-key-mode
(setq which-key-idle-delay 0.1))
** Vertico
#+begin_src emacs-lisp
  ;; Enable vertico
  (use-package vertico

    ;; Different scroll margin
    ;; (setq vertico-scroll-margin 0)

    ;; Show more candidates
    ;; (setq vertico-count 20)

    ;; Grow and shrink the Vertico minibuffer
    ;; (setq vertico-resize t)

    ;; Optionally enable cycling for `vertico-next' and `vertico-previous'.
    (setq vertico-cycle t)

  ;; Persist history over Emacs restarts. Vertico sorts by history position.
  (use-package savehist

  ;; Optionally use the `orderless' completion style.
  (use-package orderless
    ;; Configure a custom style dispatcher (see the Consult wiki)
    ;; (setq orderless-style-dispatchers '(+orderless-consult-dispatch orderless-affix-dispatch)
    ;;       orderless-component-separator #'orderless-escapable-split-on-space)
    (setq completion-styles '(orderless basic)
	  completion-category-defaults nil
	  completion-category-overrides '((file (styles partial-completion)))))

  ;; Enable rich annotations using the Marginalia package
  (use-package marginalia
    ;; Bind `marginalia-cycle' locally in the minibuffer.  To make the binding
    ;; available in the *Completions* buffer, add it to the
    ;; `completion-list-mode-map'.
    :bind (:map minibuffer-local-map
	   ("M-A" . marginalia-cycle))

    ;; The :init section is always executed.

    ;; Marginalia must be activated in the :init section of use-package such that
    ;; the mode gets enabled right away. Note that this forces loading the
    ;; package.

** Rainbow delimiter
#+begin_src emacs-lisp
(use-package rainbow-delimiters
  :hook (prog-mode . rainbow-delimiters-mode))

Can you alt+x and type ‘package-refresh-contents’ and then restart emacs

1 Like

thanks Ayan bro work panu :slight_smile:

agin one help bro
nerd-icon eppiti download pannanum?

I have installed nerd icons for doom mode line

you can install it using

alt+x nerd-icons-install-fonts

bro install panitan but vara

You are trying to change the status bar to doom mode line with nerd icons. Am i right ?

or Trying to change the font of the text in the emacs ?

yeah bro doom status bar la nerd icons venu bro

Based on the configuration above, seems like you haven’t install doom mode line

(use-package doom-modeline
  :ensure t
  :init (doom-modeline-mode 1))

drop the above the line in the config.org inside elisp block

You can execute the above command using C-x C-e or Restart the emacs

idha maari vanduthu
package-refresh-contents pannan bro
ippo work pannudu
thanks bro :slight_smile:

1 Like

Sometimes the particular package version stored in the local db is not available in remote, so it is always better to refresh the package contents before you are installing any new package thambi.

1 Like

okay bro
thanks bro :slight_smile:

@Linux_User please use tamil or English when you write in public.

Not everyone can understand Tanglish. Reading and writing tanglish will spoil all of ours language skills on English and tamil.

1 Like

சரி நண்பரே :slight_smile:
இனி தமிழில் எனது கேள்விகளை கேட்கிறேன்.