Installed Linux Mint but Bluetooth is not working

Hi Team,

Bluetooth is not working but wi-fi is working fine . Need your helping hand . Tried all the similar topics in " Tamillinux Community " but cant resolve sir .


Please brief not working.

You mean you are not able to connect to any Bluetooth speakers or headsets ??

I couldn’t see any Bluetooth symbol to enable in the laptop sir .
Also " Bluetooth Manager " is there but if I click nothing is prompting to enable Bluetooth.
Purpose : need to connect my headset


bluetoothctl power on
bluetoothctl scan
bluetoothctl devices

Execute the above commands one by one and share the final screen

Note: keep your bluetooth headset powered on during this process




Let’s check if your bluetooth device is blocked or not

rfkill list all

The above command should have no for both soft and hardblocked

Then try

sudo bluetoothctl show

Share the output of the both.


From this screenshot we can see not bluetooth available on your device

Let’s check hardware spec to see if any Bluetooth device present in your laptop.

lspci -nn

Run The command and share the output text. No need for screenshot. Because the text will be longer.

By the way do you know your laptop has bluetooth for sure before ??

By the way do you know your laptop has bluetooth for sure before ??
—> Two days before bought the laptop in second hand sir , but forgot to test the Bluetooth sir.

I think with the above command we won’t be able to find bluetooth if both bluetooth and wifi on same adapter

So kindly run the below command

dmesg | grep -i blue

If the output contains “product: bluetooth” string then your computer has bluetooth

Also can you share the laptop model we can browse in the internet and double check too


Model : DELL Inspiron 3521 sir


No need to use sir and all

Seems Bluetooth modules are loading but not sure why product: Bluetooth is not present.
Have you tried updating drivers in the driver manager in linux mint ? If not kindly run the update

I tried all the steps I know to diagnose, but I can’t find the root cause
Some experienced linux users kindly help on this thread

lsusb -vt

இந்த கமாண்டை இயக்கி வரும் தகவலை பகிரவும்.

இந்த தலைப்பில் எந்த ஒரு தீர்வும் இல்லாத்தால் தீர்வு எட்டப்படவில்லை என்று முடிக்கிறோம்.