Touchpad is not working on my Linux Mint 21.2 Cinnamon OS

I have been having this issue since i changed to linux on my machine, My Laptop Model lenovo Ideapad 310 and linux kernel 5.15.0-86-generic (stable kernel available from 5.15). I tried reinstalling libinput device and configurated the files as well, nothing works.

Can anyone help me to fix this up? Thank you in advance.

Have you tried enabling Mouse and touchpad on the settings menu?

Yes, SS attached FYR.

Check your keyboard function keys.
F1, F2 etc.

There may be a button to enable/disable trackpad.

Click that button
Test it.
Share the results here.

I tried enabling it before and now, still no luck

Can you execute the following command

cat /proc/bus/input/devices

you can paste the output in pastebin like website and share the url

Here’s the output link.

I don’t see any touchpad interface in your output, this is may be due to kernal or xorg bug (i read this from the ubuntu touch pad debugging page)

Reference for ubuntu touch pad debugging issue page: DebuggingTouchpadDetection - Ubuntu Wiki

I need to check if your system is running in xorg or wayland, can you type the below command and share the result


Also if you connect external mouse, is it working ?

Yes Ayan, My external mouse is working well. only the touchpad is not working

Can you try booting into a live linux environment with Bootable Linux USB and check out if your touch pad is working ?

இந்த சிக்கல் தொடர்கின்றதா?

இந்த தலைப்பில் நீண்ட நாட்களாக எந்த ஒரு விவாதமும் நடைபெறாததால் தீர்வு எட்டப்படவில்லை என்று முடிக்கிறோம்.