Wifi and trackpad not work

vanakkam sago
na linux mint 21 xfce use panran
trackpad ,wifi yum work pannala
extrenal mouse work panudhu



Can you tell more details about trackpad?
Is the trackpad tap is not working? Or you were not able to move the pointer itself using trackpad ?

For wifi issue,

Can you run the below command in your terminal and share the output text ? (No need to share the screenshot just the output text)

rfill list all

terminal output
adamaz@adamaz:~$ rfill list all
Command ‘rfill’ not found, did you mean:
command ‘rfkill’ from deb rfkill (2.37.2-4ubuntu3)
command ‘rkill’ from deb pslist (1.4.0-3)
command ‘sfill’ from deb secure-delete (3.1-7)
Try: sudo apt install

trackpad complete ta work pannala button and touch but na on la dha trackpad vachirukan

Thanks for adding more points in the trackpad section

Sorry for the wrong command
It is my typo

Below is the correct command

rfkill list all

The output says your wifi device is hard blocked. That means physically the power is cut off to it.

Usually this can be fixed by restarting the system. It supply the power to it again.

Fix : Kindly restart your system and run this command again. And check if you are able to connect to wifi again.

adya output dha varudhu

Okay, there are some other possibilities too.

#1 : From the hardware spec you shared from the neofetch. It think your laptop is little old.

Old laptops have physical wifi switches along with other ports or sometimes in keyboard itself.

Kindly search your laptop for this physical switch. If it is turned off you can turn on and check wifi again.

If you don’t know about the switch or confiused if your laptop has one ? You can search your laptop model in the internet to check if it has a switch.

#2: Sometimes, your laptop have airplane mode on. So kindly check that key. If it is one please turn it off

Kindly check both items


laptop details

Seems your laptop is latest only

Kindly try finding the wifi key in your laptop like mentioned in the below thread

Not sure what is the key in infocus. Maybe it is mentioned in the internet or in any manual

Not sure if you laptop has hardware key for this one but you can check.

For your reference below thread

bro bois la wifi adapter lam off pannala bro
wifi option na illa bro
enna nu ennaku theriyala orre time trackpad dum wifi problem vanthuduchi

I haven’t told the wifi was turned off in bios.

I just mentioned to check for airplane key and physical switch

That’s why i shared those two threads.

Also one more item, when was your trackpad and wifi last worked ?

thank you bro
wifi problem solved :slight_smile:
fn+f3 press panna wifi adapter on ayiduchi
trackpad work pannala bro
1 day before nalla work pannuchi
orre time dhan wifi,trackpad work pannala ippo wifi work pannudhu aana trackpad work pannala
note : os change panirukan zorin lite → linux mint 21 xfce

Wifi is good now, lets move to trackpad.

Try running

xinput --list

And share the output text here.

In one the above screenshot you shared mouse and trackpad settings, you selected button tab.

Kindly select the touchpad tab and share the screenshot

adamaz@adamaz:~$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Liteon Dell Wireless Device Consumer Control id=11 [slave pointer (2)]
⎜ ↳ Liteon Dell Wireless Device Mouse id=13 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ Liteon Dell Wireless Device id=10 [slave keyboard (3)]
↳ Liteon Dell Wireless Device System Control id=12 [slave keyboard (3)]
↳ Camera Module VGA with mic: Cam id=14 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
↳ Liteon Dell Wireless Device Consumer Control id=17 [slave keyboard (3)]

Seems the drivers are perfect.
SynPS/2 Synaptics TouchPad id=16

Can you share the Touchpad tab ? Currently you shared the buttons and feedback

The external mouse you use is a wired or wireless ?

wireless mouse

touchpad tab

parameshwar Anna
please solve pannunga

We are trying to solve only bro :smile:

First there is a default settings which may cause this situation.

Case 1: sometimes the disable touchpad when mouse connected is turned on by default.

We need to disable like below screenshot in the link shared

So you can search your inputs settings to find if you can find this option

illa bro

na disable touchpad indha setting on pannala bro